Home > Pkgadd Error > Pkgadd Error Unable To Determine Current Run-state

Pkgadd Error Unable To Determine Current Run-state

And is that any different from a "recent Kernel Jumbo Patch"? (It seems it is from what you say.) Would a "latest recommended bundle" include kernel patches? (I'm not sure I This contains information on the current system state, including run level. After putting together my package, I then try to use pkgadd -d $PWD on the directory that contains my package. (/export/kelleyt6/kelleyt6_pkg) The only hint to this error I've managed to find This was supposed to be a lot simpler than it's been.... this content

If you have any questions, please feel free to mail me. Join your peers on the Internet's largest technical computer professional community.It's easy to join and it's free. Solution Workaround: If run level 4 has not been defined, change run level to 4 and then back to 3 using the init command. I'm sitting in the directory itself so my assumption is that the -d format should work, right?It's possible, of course, that I'm entering the command incorrectly, but I do have https://www.veritas.com/support/en_US/article.000015255

Subscribe to our monthly newsletter for tech news and trends Membership How it Works Gigs Live Careers Plans and Pricing For Business Become an Expert Resource Center About Us Who We Annihilannic. The .bash file is written and is included in the package contents (it's inside protocol...and postscripts calls bash my_script.bashWhat I'm not sure of...is what pathname do I use for my_script??? check it out RE: Confused by pkgadd error JMCraig (Programmer) (OP) 31 May 06 11:29 Thanks ac325ci, the fix was to apply the patch for the package utilities.John John CraigAlpha-G Consulting,

CONTINUE READING Suggested Solutions Title # Comments Views Activity Need help in checking an rpm and install or uninstall it 3 47 44d XML::LibXML and Xpath syntax How do I get Currently i'm going to re-read through pkgmk and see if there isn't something I can do that makes my package oblivious to run-state....then I'll see if pkgtrans can help. I know the system in run level 3. Cause On Solaris, Veritas uninstall scripts call OS pkgrm package removal utility to facilitate the removal of packages in a consistent manner.

MAKE SURE YOU HAVE A GOOD BACKUP BEFORE INSTALLING KERNEL PATCHES.ThanksCA RE: Confused by pkgadd error Annihilannic (MIS) 26 May 06 09:44 These are the first few patches in the last Now that I have it...I've realized that I need a post-script to run the .bash file contained in the package. Samba put files and can't delete/modify afterwards on Solaris 8 How to block a user from telent login OS HDD not able ssh as root Categories Better Developers HomeBusiness IntelligenceDatabase Mobile http://www.eifr.com/article.php?id=916&act=print iirc, the easiest way to get around it, would be to reboot and run pkgadd again. 收藏 | 打印 | 字体: -缩小 放大+ [ x ] 请正确填写下面信息 标 签:solaris pkgadd ERROR:

Jpcap(http://netresearch.ics.uci.edu/kfujii/Jpcap/doc/index.html) Version 0.6 Prerequisite: 1. Now I'm trying to do it on the second one: it won't add the packages.FTP'd the packages from freeware.sun.com (it has a number of different packages which are required, but the They're just trying to get some holes patched in this thing so it will last a bit longer.Thanks again!John John CraigAlpha-G Consulting, LLCwww.alphagconsulting.com RE: Confused by pkgadd error kHz (MIS) 25 RE: Confused by pkgadd error JMCraig (Programmer) (OP) 26 May 06 13:11 Hi Folks,Hearty thanks, kHz, for hanging in there with me (although I didn't mark any particular post of yours

Thank You! http://www.unix.com/solaris/39034-unable-uninstall-package-solaris.html Use is subject to license terms. If there is no match or if pkgrm is unable to check the current system run level, package removal is inhibited.If pkgrm is asked to remove a package which does not It is avail… Unix OS Using libpcap/Jpcap to capture and send packets on Solaris - Part 1 Article by: Santosh Using libpcap/Jpcap to capture and send packets on Solaris version (10/11)

Learn more.from there you will get to clusters page and can search for clusters pertaining to the OS you are working on, and yes it includes the latest Kernel patch.Thanks CA news All rights reserved. This is the first thing Sun will tell you to do.OBP patch can be found at below link; (look at quick facts section Flash PROM, this is a public patch so Brendan -- Top 1.

I'm not even sure if rebooting it will help as this tidbit is the ONLY response I've seen to this error. postinstall script doesn't run during pkgadd 9. It turns out that the pkgadd command uses the who command to determine the current run state of the machine. have a peek at these guys Remove advertisements Sponsored Links chrisanto_2000 View Public Profile Find all posts by chrisanto_2000 #2 06-25-2007 sysgate Unix based Join Date: Nov 2006 Last Activity: 18 December 2014,

Error Message pkgrm: ERROR: unable to determine current run-stateRemoval of failed (internal error).No changes were made to the system. Then when I do the pkgadd command it complains strangely:# pkgadd -d openssh-4.3p2-sol8-sparc-localpkgadd: ERROR: no packages were found in Is this a way of saying the the file is corrupted somehow PKGADD can't find run-state by stealt » Tue, 22 Sep 1998 04:00:00 When I run pkgadd to install GNUgcc 2.8.1 compiler on Solaris 2.5.1 I get this error message: Processing package

open... no packages were found in /var/spool/pkgpkgadd open... no packages were found in /var/spool/pkgMove the openssh package to /var/tmp and run pkgadd -d /var/tmp/open..

Go to Solution 3 Comments LVL 76 Overall: Level 76 Linux 38 Unix OS 20 Message Active today Expert Comment by:arnold2011-06-23 My guess the command the script tries to run openssh-4.3p2-sol8-sparc-localksh: /var/tmp/baaKJayP5: cannot openHi kHz,Given your experience, I guess I'll recommend my clients not try upgrading the OS!Your results:Quote:pkgadd -d openssh... pkgadd -d /var/downloads/open... pkgadd -d . The package contains information in the form of an RSTATES flag along with the specific run levels where the package can be removed.If pkgrm is asked to remove a package which You may also refer to the English Version of this knowledge base article for up-to-date information.

Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework. pkgadd can't find packages in /var/spool/pkg 6. Join the community of 500,000 technology professionals and ask your questions. check my blog Solved Solaris error using pkgadd pkgrm: pkgadd: ERROR: unable to determine current run-state Posted on 2011-06-23 Linux Unix OS 1 Verified Solution 3 Comments 1,483 Views Last Modified: 2012-06-27 I am